Страница 1 из 1

Стримротатор и PHP 7.4

Добавлено: Пн янв 27, 2020 4:04 pm
dmmcash
Привет

Будет ли версия стрима для 7.1 работать на PHP 7.4?

Просто PHP 7.4 сейчас по умолчанию ставиться для Centos7. Я на новый сервер переезжаю, и думаю необходимо ли заморачиваться с понижением версии PHP?

Спасибо.

Re: Стримротатор и PHP 7.4

Добавлено: Пн янв 27, 2020 4:52 pm
dushik
не могу сказать, не тестил

Re: Стримротатор и PHP 7.4

Добавлено: Пн янв 27, 2020 5:20 pm
dmmcash
Ясно, спасибо.

Ну на 7.2 я поставил на одном серваке, вроде все корректно работает. Тогда ее и буду ставить.

Re: Стримротатор и PHP 7.4

Добавлено: Чт апр 02, 2020 7:48 am
dmmcash
Планируешь ли ты делать версию для PHP 7.4? Думаю это уже актуально. Я пробовал ставить текущий вариант скрипта на тестовый сервер, почти работает но часто вылезает ошибка 500. Вобщем не стал на рабочий сервер ставить PHP 7.4.
Сейчас у меня на PHP 7.2 работает, даже там если в логи глянуть многовато ошибок, точнее WARNING для PHP и error in your SQL syntax. Хотя внешне это незаметно.

Или уже будешь сразу под PHP8?

Re: Стримротатор и PHP 7.4

Добавлено: Чт апр 02, 2020 9:48 am
dushik
для 7.4 пока нет кодировщика ioncube
если есть какие-то ошибки или варнинги, на них нужно обращать внимание. можно выслать их мне

Re: Стримротатор и PHP 7.4

Добавлено: Чт апр 02, 2020 11:24 am
dmmcash
Да, ioncube у них бета пока, но вроде работает. Я на его основе и поставил на тестовый сервер твой скрипт. Вобщем понял. будем ждать нормального кодировщика. А логи я тогда упакую и вышлю в личку.